Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2026 - 20:30 EDT
Scheduled
We will be performing scheduled maintenance to deploy an updated version of our platform. During this window, the service may be intermittently unavailable while updates are applied.
This release includes: • Improved medical record organization and reviewability • Stability fixes and minor enhancements
Posted Jul 22, 2026 - 18:42 EDT
This scheduled maintenance affected: Partner API (Partner API – Production, Partner API – Sandbox) and Platform (Web Application) (Patient & Request Management, Reporting & Exports).