The issue affecting HIE facesheet processing has been resolved.
All outstanding facesheet requests have been successfully backfilled and processed. HIE facesheets are now processing normally, and the service has returned to normal operation.
Thank you for your patience while we worked to resolve this issue.
Posted Aug 28, 2026 - 19:54 EDT
Identified
We have identified the cause of the issue affecting HIE facesheet analysis. HIE facesheet requests are currently experiencing processing delays and are accumulating in a queue.
The issue affects HIE facesheets only. Provider facesheets and previously completed requests remain unaffected, and no data has been lost, corrupted, or exposed.
Our engineering team is implementing and testing a resolution. We will provide another update as soon as more information becomes available.
Posted Aug 28, 2026 - 14:35 EDT
Update
We have identified that provider facesheets are processing normally and remain unaffected. The issue is limited to HIE facesheets, which may experience delays in analysis turnaround times.
Our engineering team is actively investigating the issue and testing a resolution. Existing data and previous submissions remain secure and unaffected. We will provide another update as soon as more information becomes available.
Posted Aug 28, 2026 - 14:29 EDT
Investigating
We are investigating an issue causing delays in receiving facesheet analysis results. Our engineering team is actively working to identify the root cause and restore normal processing as quickly as possible.
Existing data and previous submissions remain secure and unaffected. We will provide another update once more information is available.
Posted Aug 28, 2026 - 13:42 EDT
This incident affected: Platform (Web Application) (Data Retrieval – Facesheets).